Login [Register]
Don't have an account? Register now to chat, post, use our tools, and much more.
I am using Chrome version 63.0.3239.132 on windows 10 pro.
I expected the image to be cropped down to a small size.
It was not very small.



I was able to replicate this in Microsoft Edge version 41.16299.15.0
I tried replicating this in Internet Explorer version 11.192.16299.0, and the issue got much worse.




Legoman314 is the only user I've ever seen this happen with, but his image is very large (1920x1200)

Here is a link to his profile
And here is a link to the picture.
Because I'm on CemetechRetro, it sort of messes up the whole page as well. (Not really, but it's annoying). I sometimes like CemetechRetro over Cemetech6, so...
I'm so sorry, I didn't realized it was that big, I have changed it to a 100x100 image. Hope it works. Sad Smile
It's soo much better! Thanks!
you're welcome! Smile
Well, that's great and all, but there is still a problem... The purpose of this post wasn't to get you to change it, but rather to nag Kerm about fixing his site Laughing
Also, it appears they've locked the bug reports thread and now encourage users to make individual threads for each bug?
Looking at the css, there is nothing regulating the max-height and max-width of the profile picture, but there is some code for doing so when it is shrunk to put in posts. I think simply adding something like

Code:
max-width:100;max-height:100;


to the profile_avatar class should do it, but I can't reproduce it now that it has been changed by the user. I think the image was taking up the width of the container (with some margin value) which is why it would appear the way it did, but that makes me wonder how all the other images managed to stay the right size.

EDIT: I've went and checked and the issue is a little bit less front-end. The user used the "Link to off-site Avatar" option. This option is probably very unpopular, which is probably why I've never seen this happen. When you upload an avatar from your pc, it checks and asks that the image be less than 29kb, but this check seems to not be present when linking to an offsite avatar. Somebody should have a look at the code for that, and somehow make it check that the offsite avatar is small.
Or just remove it, because nobody uses it Evil or Very Mad .
mr womp womp wrote:
Also, it appears they've locked the bug reports thread and now encourage users to make individual threads for each bug?


That is correct. Makes the discussion easier to track in the long run.

Quote:
EDIT: I've went and checked and the issue is a little bit less front-end. The user used the "Link to off-site Avatar" option. This option is probably very unpopular, which is probably why I've never seen this happen.


Very astute observation! I'll add this to the issue list in the repo.
  
Register to Join the Conversation
Have your own thoughts to add to this or any other topic? Want to ask a question, offer a suggestion, share your own programs and projects, upload a file to the file archives, get help with calculator and computer programming, or simply chat with like-minded coders and tech and calculator enthusiasts via the site-wide AJAX SAX widget? Registration for a free Cemetech account only takes a minute.

» Go to Registration page
Page 1 of 1
» All times are GMT - 5 Hours
 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

 

Advertisement