Just picked up a TI 83 Plus from Goodwill for a couple of $$$. It works, but acts up every now and then. The cursor blinks about 4 times per second, but sometimes it blinks so fast that I can't count it. Also, sometimes it won't accept any keys and I have to remove a battery to turn it off. I can get it working again by removing and replacing the battery. It's nothing that I'm going to use on a regular basis, just adding it to my calculator collection. Just wondering why the cursor blink changes speed. When the cursor is blinking fast, the scroll seems to go faster, but if I run a program, it doesn't look like that runs faster. There doesn't seem to be any reason why the cursor goes so fast. Sometimes it's fast when I turn it on, other times it speeds up after a short time.
faster? aye, weird. I once had it when the calc stopped accepting input and it acted slow, because some dirt of sorts got into the link port, so maybe try cleaning it out? dunno for sure.
Could we have a video of what is happening?

Perhaps that will help others solve your issue, as it is a little weird.

I have no experience with the 83+, but have you tried re-installing the OS?
Luxen, I'll try cleaning the link port. I have a pack of little brushes that I use between my teeth. Maybe that will do something. _iPhoenix, Reinstalling the OS is more than I want to get into. I've never done that and I don't know if I have the cables and whatever else I need. As for the video, it would just show the cursor blinking really fast. Faster than I could count it. I took the batteries out and let it sit for about a hour. When I put the batteries back in and turned it on, it said that RAM was cleared. I pressed ENTER and the cursor was blinking at 2 times per second. I took the round battery out and checked it, completely dead. It's a CR1616. I think I tried looking for one of those before and couldn't find one. As I said, it's not a calculator that I would use, but just an addition to my collection. I normally take the batteries out because they don't get used. I was just curious as to why the cursor would blink really fast on its own and sometimes not accept any key strokes.
It could be something strange happening with the OS interrupt due to the link port, or it could be some kind of hardware issue with a timer. I'm not 100% across the schematics, though perhaps Kerm or something a little more familiar will be able to help.
I found a plug that fit the link port and put some old tape head cleaner on it and pushed it in and out of the plug several times. There wasn't any resistance, so I don't think anything was stuck in there. I don't want to take up people's time on this. I just thought someone might have run into this and have an answer since the 83 Plus has been around for a long time. It seems that if I take the batteries out long enough so that I get RAM CLEARED when I put them back in, the cursor then blinks at 2 times per second. After playing with the calculator for a few minute or so, it starts blinking faster and at some point won't accept keystrokes again until I remove the batteries.
  
Register to Join the Conversation
Have your own thoughts to add to this or any other topic? Want to ask a question, offer a suggestion, share your own programs and projects, upload a file to the file archives, get help with calculator and computer programming, or simply chat with like-minded coders and tech and calculator enthusiasts via the site-wide AJAX SAX widget? Registration for a free Cemetech account only takes a minute.

» Go to Registration page
Page 1 of 1
» All times are GMT - 5 Hours
 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

 

Advertisement