No, I'm guessing that was the second to last version of LibHelper that had got sent to me. I did notice that it skipped over one of the % signs for going to the next line. I haven't rechecked now that I've fixed and modified the appvar, something I'm going to check into here shortly.

And the base converter can be added in, with no trouble Smile I just wasn't sure if we wanted it. You still seemed on the fence about it being needed. :p
Alright, I've gone over it a final time, and I hope I've found all the typos and changes from letters to greek characters. Until tr1p1ea gives me more information to add in, I'm considering this 'done' and ready for release when DCSE 8.1 RC comes out.
tifreak8x wrote:
Alright, I've gone over it a final time, and I hope I've found all the typos and changes from letters to greek characters. Until tr1p1ea gives me more information to add in, I'm considering this 'done' and ready for release when DCSE 8.1 RC comes out.
Great, thanks for keeping on top of this. The only changes to Celtic 2 CSE are bug fixes, so as you probably already guessed, there's nothing new there.
Yep, that much I knew Smile Just no idea what tr1p has in store for me to add.
Holy cow. I finally have the text data set up and ready to be organized into the actual appvar.

The additions tr1p1ea made to DrawSprite will add 16 pages of text (calculator screen sized)

Going to take a bit to get it all put into the appvar, then all that is left is DrawMap, but that shouldn't take long at all to convert over and get put in, just 2 small paragraph looking things.
Got the new stuff for DrawSprite put into LibHelper, added an additional 6,583 bytes to the appvar, bringing the total size so far to 47,967 bytes. Last on the list of things to add in is the additions to DrawMap, hope to have that done, maybe tonight if I don't end up dying from construction work. The additions done there shouldn't take too long to add in.

(Note to self: )

Forgot to update, DrawMap has been included in the appvar with all the data. It's huge. I'm contemplating throwing DrawSprite in to 2 separate sections, it's gotten so large that the calc has trouble sub(ing out the string as it reaches the end. I'm waiting on KermM to take a look and get his opinion on the matter. If I do that, it won't really change much in the program, and will allow me to test the adaptability of the menu system.
LibHelper updated with typo fixed in xlibc function. Uploaded in Cemetech archives, pending at
if you select xlib (not the color table) and scroll through a few pages it throws a domain error. i think the problem is that some text needs to be removed on the page so it will fit on the calc screen.
Graphing Calculator
This does indeed happen under xLIBC Library -> GetKey on the sixth page (ManagePic header). I paged through using Enter.
The rest of the sub-menus in xLIBC Library are fine.
I just used the newest version of DCSE to run this, and ran into no errors at all. Do you have everything in Archive when running this?
Hmm I saw this post and just grabbed my calculator, I got the same error and the line of code is
If B:Text(2+12B,1,sub(Str9,X,Ans-X
I have DoorsCS8.1 and the program is in Archive. The error occurs on page 7 of the Getkey section in the xLIBC Library section with the header "ManagePic"
It appears as if there is no more room for text.
Again, do you have ALL of YOUR programs on the calc in Archive, not just the ones to run LibHelper. Some of that string data is massive, and it might not all make it back to the string if you don't have enough RAM to run it.
Here is a screenshot of the bug:
That makes no sense :<

And I thought it was a problem with manage pic, which worked fine, I'll see what I can figure out on this, though I'm wondering if celtic is pulling from more than one spot of the appvar or something. The appvar itself has no indication of errors with that line. I'll get Kerm in on this and see what he thinks.
Yes that screenshot shows exactly what happened. So this error doesn't happen for you? Tifreak it might be helpful if you also posted a screenshot of how the page should work. Has the program been updated recently? I downloaded it about 1 or 2 weeks ago.
No, it hasn't been, and as I mentioned, I thought the issue was stated being in Managepic, not in getkey. I've only looked at the code, and it seems that the code is correct for it, but something else is being pulled along and that makes no sense. Testing will be done to figure out the cause.
How does it go straight from getKey examples to manage pic while skipping everything in between? Or is it not? Argh what is the reason for this!
Digging through, it seems somewhere along the lines, some of managepic has merged with the getkey line. This makes no sense what so ever. Neutral I'll have to fix up the appvar and release an update. I just have to figure out what is missing and what else might be messed up.


Sorry to you guys that reported and I misunderstood. New file now in the archives that should resolve this bug, that I still don't know how it got in there. :/
Alright cool thanks for the help Smile
Register to Join the Conversation
Have your own thoughts to add to this or any other topic? Want to ask a question, offer a suggestion, share your own programs and projects, upload a file to the file archives, get help with calculator and computer programming, or simply chat with like-minded coders and tech and calculator enthusiasts via the site-wide AJAX SAX widget? Registration for a free Cemetech account only takes a minute.

» Go to Registration page
» Goto page Previous  1, 2, 3, 4, 5, 6  Next
» View previous topic :: View next topic  
Page 5 of 6
» All times are UTC - 5 Hours
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum