Login [Register]
Don't have an account? Register now to chat, post, use our tools, and much more.
My TI-84 Plus C Silver Edition keeps acting odd. If I pass the ON button it won't do anything and if I hold the on button down the screen will blink on and off. ALSO! It will ALWAYS tell me that I'm almost out of battery (this happens when it will turn on, which it won't lately) and this will happen even if I just charged it. Can someone please help me figure out the source of the problem and how to fix this?
Just wondering if pressing the little reset button on the back of the calculator does anything? (Note that pressing this may cause some loss of data).
There have been quite a number of TI-84+CSE calciulators with similar hardware issues, unfortunately. While tr1p1ea's suggestion is worth a try, your best recourse is getting in touch with TI-CARES via 1-800-TI-CARES to try to get it replaced under the warranty.
It sounds like the battery is toast. Call TI CARES and tell them about your problem; they may replace the whole calculator. Unfortunately, TI didn't make provisions for directly running the calculator off USB power when the battery is damaged, so you can't get your data back easily.

If you know another student or teacher with a TI-84 Plus C SE, you can find out whether the battery is the problem by swapping batteries; if your calculator works with a known-good battery, then you just need a new battery.

If the calculator isn't under warranty and TI won't take it back, and you can determine the issue is the battery, you can purchase a new one here. $10 is a very good price for a LiPo battery.

They really ought to release an OS update allowing running directly off USB power (if that's possible), with a built-in battery diagnostic, and put a boot code update into production addressing that issue. They should also add a hardware low-voltage cut-off.
Unfortunately, I don't live in the States, so I don't think I'll be able to replace mine Sad I've tried resetting it, I've even done it with holding the del key at the same itme... nothing works Sad
Texas Instruments has warranty facilities in other countries as well, as far as I know. They're generally pretty good about handling hardware issues that are genuinely problems with their design or QC, so I still recommend you pursue warranty replacement.
  
Register to Join the Conversation
Have your own thoughts to add to this or any other topic? Want to ask a question, offer a suggestion, share your own programs and projects, upload a file to the file archives, get help with calculator and computer programming, or simply chat with like-minded coders and tech and calculator enthusiasts via the site-wide AJAX SAX widget? Registration for a free Cemetech account only takes a minute.

» Go to Registration page
Page 1 of 1
» All times are GMT - 5 Hours
 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

 

Advertisement