Having successfully linked to 83+/84+ to my arduino, I am now working on my 86. While I can send numbers to and from and get the 86's directory, any time I try to send commands, I get spectacular crashes of the 86 (have to pull the batteries for a few minutes to get it back). The format seems to be the same as the 83/84+, but sending 06 87 09 00 does not clear the screen or seem to do anything. When I tried to do A/b sto C it crashed as above. Anybody have any ideas?
Well for one you are sending the delete key rather than Clear, so that would explain your screen not clearing. The link guide appears to assume it is the same as the 83+ which according to libticalcs is not the case. I got the Key code from https://github.com/debrouxl/tilibs/blob/master/libticalcs/trunk/src/keys86.h

As for why the directory listing isn't working it might be worth playing with the timing, from what I recall the 86's slower processor requires you to increase bit and byte delay timing. It may be worth a shot putting some slight delays in the code between checking and setting gpio's.
Thanks for the codes, I'll check them out. My directory listing is working fine, but anytime I send keystrokes -- boom. Crying
Tried the 86 clearscreen command 0x0008. and it worked! Now for more tests!
Register to Join the Conversation
Have your own thoughts to add to this or any other topic? Want to ask a question, offer a suggestion, share your own programs and projects, upload a file to the file archives, get help with calculator and computer programming, or simply chat with like-minded coders and tech and calculator enthusiasts via the site-wide AJAX SAX widget? Registration for a free Cemetech account only takes a minute.

» Go to Registration page
Page 1 of 1
» All times are UTC - 5 Hours
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum