Login [Register]
Don't have an account? Register now to chat, post, use our tools, and much more.
I am trying to make a doors asm app that just has an icon at the moment. Why do I get this error?


Code:
.nolist
#define TASM
#include "ti83plus.inc"
#include "dcs7.inc"
.list

   .org progstart
   .db $BB, $6D

Init:
   xor d
   ret
   jr Start
   
   .dw $0000
   .db $07, $00
   .dw Icon
   .dw $0000

Icon:
   .db %11111111,%11111111
   .db %10000000,%00000001
   .db %10000000,%00000001
   .db %10000000,%00000001
   .db %10000000,%00000001
   .db %10000000,%00000001
   .db %10000000,%00000001
   .db %10000000,%00000001
   .db %10000000,%00000001
   .db %10000000,%00000001
   .db %10000000,%00000001
   .db %10000000,%00000001
   .db %10000000,%00000001
   .db %10000000,%00000001
   .db %10000000,%00000001
   .db %11111111,%11111111
   
Start:
   ret
Well, I see no problems with your header. Does the icon get displayed properly when you start Doors CS? Which version of Doors CS are you using?
No, no header and 7.2 I think, timestamp is 12/30/2010.
gudenau wrote:
No, no header and 7.2 I think, timestamp is 12/30/2010.


That's not right. 7.1 was released on 01/01/2011 and 7.2 was released as a second beta on 06/13/2012.
By header I meant that this part is fine:
Code:
   .org progstart
   .db $BB, $6D

Init:
   xor d
   ret
   jr Start
   
   .dw $0000
   .db $07, $00
   .dw Icon
   .dw $0000

Icon:
So when you launch Doors CS, you don't see the icon, and when you run your program, you get the 502 error? I'm baffled that something is going wrong when my documentation on the header format says that you have it right.
I don't know, there is no image...
Also, are you using the Doors CS SDK and Brass to compile this? What's with the #define TASM marking? You're on a TI-83 Plus, not a TI-83, right?
I have TI84PSE, and I am using the doors sdk files...
gudenau wrote:
I have TI84PSE, and I am using the doors sdk files...
I compiled your program and sent it to my calculator, and everything is working properly. I bet I know the problem: when you compile, you should type "compile blah", not "compile blah.asm", and not "compile blah.z80".
I am typing "compile hellodoors". why does my calculator hate me?
gudenau wrote:
I am typing "compile hellodoors". why does my calculator hate me?
Because "hellodoors" is more than 8 characters. Smile Try "hellodcs" with hellodcs.asm producing hellodcs.8xp and see if that makes a difference.
Ok.
That worked, thanks a bunch!
This seems like a bug in the sdk not doing proper checking?
  
Register to Join the Conversation
Have your own thoughts to add to this or any other topic? Want to ask a question, offer a suggestion, share your own programs and projects, upload a file to the file archives, get help with calculator and computer programming, or simply chat with like-minded coders and tech and calculator enthusiasts via the site-wide AJAX SAX widget? Registration for a free Cemetech account only takes a minute.

» Go to Registration page
Page 1 of 1
» All times are GMT - 5 Hours
 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

 

Advertisement