KermMartian wrote:
CalebHansberry wrote:
So far, I hate Ubuntu! It has no drivers available for it so I can do very little, has crashed several times, and I have failed every time I have tried to install a program.
What sort of drivers? It pretty much has drivers built-in for everything. What sort of crashes? What programs have you tried to install?

I need drivers for my Netgear Wi-Fi adapter and, less importantly, my Intel Extreme Graphics. And my 3 1/2 floppy drive doesn't work.

The crashes happen randomly, like when I'm using LibreOffice or viewing my USB flash drive, and consist of just freezing and not reacting, even to the power button. Wherupon I need to unplug the computer.

The programs that I tried to install but failed are QB64, Java, and TiLP.
Hmm... sounds like what happened to me when swap was not enabled.

Try running top in command line and see what it says next to "swap"
The programs that I tried to install but failed are QB64, Java, and TiLP.

I'm afraid you're not doing it correctly, as TILP can be compiled very well on Ubuntu Wink

And as hinted above, you should post us the result of `sudo lsusb` and `sudo lspci`. There must be some graphical versions of those, but they're not easier to copy & paste.
flyingfisch wrote:
Hmm... sounds like what happened to me when swap was not enabled.

Try running top in command line and see what it says next to "swap"

Yeah, you're really screwed if you didn't make a swap partition; check out Tari's article on swap if you need help deciding what size partition you need. This section appears to have the cause of your dillema.
Since 2007, none of the computers with 2 GB of RAM or more that I administer has a swap partition.
* I don't use suspend to disk, which would be a major reason to have a swap partition;
* I seldom intentionally run anything that doesn't fit in RAM (and if I do, I just create a swap file on another media);
* even though once in a while, one of the machines thrashes, Linux's OOM killer tends to work significantly better nowadays, after the rewrite landed in 2.6.35 or 2.6.36.

Even with a fast rotational HDD, only some peculiar workloads (swapping out pretty much every application but the one that consumes lots of RAM but just fits into RAM) make it possible to have more than ~1 GB of used swap without the machine thrashing into oblivion Smile
Even with fast SSDs, running workloads which do not fit in RAM, and constantly touch the entire memory they have allocated is very slow.
I've hit situations where a machine with 8GB of RAM slowed to a crawl without any swap enabled.
The situation: am pushing files onto a large but slow external storage device (flash-backed). Kernel caches the writes and continues pushing data out as fast as the device will take it (a few megabytes per second). Suddenly Firefox wants a little more memory, but memory is full of write buffers.

Without swap, it just has to wait for the write buffers to flush in order to free some memory and give it to firefox. This took minutes on end in some cases where the system was basically frozen.
With even a little bit of swap enabled, it could page something unimportant out and give its memory to firefox.

That's my $0.02. Good to have at least a little swap, but the only reason to have more than a small amount is for suspend to disk.
Register to Join the Conversation
Have your own thoughts to add to this or any other topic? Want to ask a question, offer a suggestion, share your own programs and projects, upload a file to the file archives, get help with calculator and computer programming, or simply chat with like-minded coders and tech and calculator enthusiasts via the site-wide AJAX SAX widget? Registration for a free Cemetech account only takes a minute.

» Go to Registration page
Page 3 of 3
» All times are UTC - 5 Hours
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum