I think this was the correct topic to post in, but anyways;

in my Digital Electronics class (PLTW) we have learned what msot of the gates do, (and, or, inverter, NAND, and NOR ) and we have learned how to breadboard. Our latest project is to use a seven-segment display_com_K, to display our date of births using 3 switched. mine went as followed (truth table)... D would be the number displayed with the given switches, and the hyphen is for in between numbers ex; MM-DD-YY


Code:
x  y  z  D   a  b  c  d  e  f  g
0  0  0  0   1  1  1  1  1  1  0
0  0  1  9   1  1  1  0  0  1  1
0  1  0  -   0  0  0  0  0  0  1
0  1  1  1   0  1  1  0  0  0  0
1  0  0  1   0  1  1  0  0  0  0
1  0  1  -   0  0  0  0  0  0  1
1  1  0  9   1  1  1  0  0  1  1
1  1  1  3   1  1  1  1  0  0  1


with the given truth table; there are 7 circuits total, 1 for each letter (led on the seven-seg). for the circuits, he wanted two done in just NAND gates, two in just NOR gates, and the rest can be done in whatever gates you want, i chose aoi logic gates (and, or)
i made my whole circuit on a program called multi-sim, and it worked. two of my circuits are the same (B,C according to the truth table above).

i stayed after in engineering today just to finish this breadboard, and when i was all done, i plugged in my breadboard companion, and my stomach dropped. all the numbers worked except for the first number (0) and the last number (3). In the 0, the D,E segments weren't lighting up, and in the 3 the D segment wasn't lighting up. It worked on multi-sim; and the weird thing is both those circuits (D,E) were done with NOR gates. I did another breadboard with NAND and NOR gates together, and the nor didn't work correctly on that circuit either. I traced my wires atleast 20 times and each time i noticed they were correctly placed but just something isn't going right. any ideas? Sad((
Out of curiosity, what's your NOR chip's 74LSxxx number, just to make sure you're actually using a NOR IC. Smile
well off hand i believe it is...
HD74LS00P
joshie75 wrote:
well off hand i believe it is...
HD74LS00P
That's a NAND chip, for starters. Smile
Well then it was the HD74LS02P, I didnt know for sure, because my breadboard is at school still, but i made sure i had the NOR where need be.
joshie75 wrote:
Well then it was the HD74LS02P, I didnt know for sure, because my breadboard is at school still, but i made sure i had the NOR where need be.
And you're definitely using all TTL; you didn't mix CMOS and TTL chips?
whats the difference between TTL and CMOS?
companies?
joshie75 wrote:
whats the difference between TTL and CMOS?
companies?
Nooo, not at all. They are two different technologies, and do not operate at the same voltage levels. You can't (easily) mix TTL and CMOS logic ICs for that reason without some level sanitizing.

TTL: http://en.wikipedia.org/wiki/Transistor%E2%80%93transistor_logic
CMOS: http://en.wikipedia.org/wiki/CMOS
hmmm IC... (pun intended)
How can i tell the difference between the TTL and CMOS; is it labeled on the IC?

Btw, if it matters, all my IC's are 14pin, and 4 Gates per IC.
Yeah, almost all CMOS and TTL chips are all 14-pin ICs, so you can't tell that way. TTL chips just about all have 74LS designations of some sort; if any of your chips have other designations, you might have problemss.
alright ill make sure to check those tomorrow in class. any other suggestions? my teacher said there might be a problem taking power through nand and nor. He's a smart guy, but I feel like that shouldn't be a problem.
joshie75 wrote:
alright ill make sure to check those tomorrow in class. any other suggestions? my teacher said there might be a problem taking power through nand and nor. He's a smart guy, but I feel like that shouldn't be a problem.
Well, do you have a multimeter to check the voltage levels at the inputs and outputs? I assume you checked the pinouts very very carefully, since there are some nonstandard layouts?>
yes, I check every pin very carefull, trust me Razz lol. We do have multimeters at school. If My power supply, is a 9V batter that goes into the companion, which ends up supplying 5V to the circuit (VCC i believe) should the power read 5V on the multimeter at each IC?
joshie75 wrote:
yes, I check every pin very carefull, trust me Razz 0x5. We do have multimeters at school. If My power supply, is a 9V batter that goes into the companion, which ends up supplying 5V to the circuit (VCC i believe) should the power read 5V on the multimeter at each IC?
More or less. As long as it's in the range of 4.5-5.5V, you should be OK. Circuits that have a lot of TTL ICs should also get a handful of .1 uF or .01 uF capacitors between the power rails.
Now more about these capacitors... Where should they be placed, and what would their function be.? Smile
joshie75 wrote:
Now more about these capacitors... Where should they be placed, and what would their function be.? Smile
When you have a lot of logic ICs sharing one set of power rails, and they're all operating, the fluctuations in rail voltage due to the varying current drain and a less-than-perfect power supply can cause glitches, flipped bits, and all kinds of headache-inducing, hard-to-trace failures. Putting a capacitor or two between the power lines can smooth out these fluctuations. However, you need to be careful to not use too much capacitance, or you'll just cause your own version of the fluctuation problem, phase-shifted by the time constant of the capacitors you're using.
Ahhh, makes sense!
So if I have 11 ICs, How many Capacitors do you think I should use?
joshie75 wrote:
Ahhh, makes sense!
So if I have 11 ICs, How many Capacitors do you think I should use?
You could take a look at the Wikipedia article on decoupling capacitors for some more details; specifically, look at the information on transient load decoupling, which is what you would want to do. Various articles I'm seeing suggest one 0.1uF capacitor right next to the Vcc of each IC, which sounds a bit excessive to me. I'd just experiment and see if it helps to add a handful or not.
Thanks so much for all the help, I'll be sure to report back to see what works/ doesn't work. Smile
joshie75 wrote:
Thanks so much for all the help, I'll be sure to report back to see what works/ doesn't work. Smile
Excellent, I look forward to the reports.
  
Register to Join the Conversation
Have your own thoughts to add to this or any other topic? Want to ask a question, offer a suggestion, share your own programs and projects, upload a file to the file archives, get help with calculator and computer programming, or simply chat with like-minded coders and tech and calculator enthusiasts via the site-wide AJAX SAX widget? Registration for a free Cemetech account only takes a minute.

» Go to Registration page
Page 1 of 1
» All times are GMT - 5 Hours
 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

 

Advertisement