Login [Register]
Don't have an account? Register now to chat, post, use our tools, and much more.
geekboy1011 wrote:


this happens to me plenty of times when sending Joltima and Dying Eyes with Ti-Connect. I am just waiting for the next version of TILP with SIGNED DRIVERS! in all, it is usually a fault with Ti-Connect..... Idk how to fix it though Sad
Does it run under the original xLib app?
I believe it does have not tried that. I will try now also i used ti-connect and tilp to send it over.

Ok tested on wabbit works fine with the original xlib app but not dcs.
Hmm. After looking at the program with SourceCoder, I didn't see anything that looked corrupted, so it is almost certainly a DCS bug. Surprised
geekboy1011 wrote:
I believe it does have not tried that. I will try now also i used ti-connect and tilp to send it over.

Ok tested on wabbit works fine with the original xlib app but not dcs.
That's unfortunate. Sad I bet if you try it out with Celtic it will crash, though. Would you mind trying if you get a chance?
It doesn't crash with c3 instead it just doesn't display right at all. X.x

geekboy1011 wrote:
It doesn't crash with c3 instead it just doesn't display right at all. X.x

Oh wow, that is indeed quite glitchy. Can you narrow down where the crash is happening, by any chance? That would help me a lot in tracking it down.
Nope Nodda at least not in wabbit. Soon as it opens the editor its got garbage on it. :/ Might be a question for nitacku though as i don't know the source code.
Wait, you can't even edit it o.o Before or after running it once and crashing it?
Can you edit it without the Doors CS hooks installed?
After, before you run it you can edit it, and its not corrupted. soon as it crashes though if you hit goto it wont let you see the erriorng line, and it corrupts at the same time.

@souvik it edits fine in dcs before running it
This is a lot to ask of you, so if it's a big problem I can work together with you on it, but could you sprinkle in a few Pauses in between the beginning and where it (might be) crashing, break at each pause, and see if/when the code gets corrupted? I'm sure the reason it displays wrong but differently-wrong behavior on C3 and DCS is the same, and it's just that C3 and DCS handle that problem differently. Perhaps Nitacku is exploiting some undocumented xLIB feature?
He might be I shall ask him / look at it later. Not so much in to mood to learn another persons source code again. (read: cadan was enough X.x)
Hmm.... Did you try a ram clear, then running it again and see what happens? Or is the program itself corrupted (like when you open it without running it and breaking it) to look at it.
It sounded like he was indeed running it from a fresh calculator image. Sad
It was fresh image on wabbit as well as a fresh install on my calc. (I just wiped my os and archive cause it was over cluttered)

So its not a ram issue.
  
Register to Join the Conversation
Have your own thoughts to add to this or any other topic? Want to ask a question, offer a suggestion, share your own programs and projects, upload a file to the file archives, get help with calculator and computer programming, or simply chat with like-minded coders and tech and calculator enthusiasts via the site-wide AJAX SAX widget? Registration for a free Cemetech account only takes a minute.

» Go to Registration page
Page 2 of 2
» All times are GMT - 5 Hours
 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

 

Advertisement